Summary
When deleting the last line of a sales order, through the importing process using the standard template SOHFL, the error occurs. All other lines can be deleted without error using the import.
Cause
This issue is a known bug that was reported in 2023 R2 (12.0.34)
Resolution
This issue is fixed from 2024 R2 (12.0.36) onwards
The workaround is to delete the last line in Sales Order Entry (GESSOH)
Steps to duplicate
Tested on 2023 R2 (12.0.34) using SEED data:
- Sales – Orders – Orders (GESSOH) - Create a Sales order with 3 lines for different products (BMS001, BMS003 and BMS007) with distinctive quantities (5, 10 and 15) so that you can easily identify the QTY field in an exported file.
- Usage - Imports/exports - Exports - Export the Order using the SOHFL template
- In notepad edit the export file, setting the QTY to zero in the last line and save it.
- Usage – Imports / Exports – Import (GIMPOBJ) - Import and note an error as above.
- In notepad edit the export file, restoring the QTY in the last line, and setting QTY to zero on the second line.
- Usage – Imports / Exports – Import (GIMPOBJ) - Import the file again and note a successful update